* Notice

Important notice: From 20/12/2017 (after a server change) Microsoft had been blocking email from If you have a Hotmail, Outlook, or email address (or have been trying to message a member with such an email address) your messages might not have got through. You may also have been unable to receive password reset/activation emails. As of 31/01/2018: our server's new IP address, previously used by a spammer, has been unblocked. You may wish to try again if you have been having problems.

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Game refuses to use dedicated GPU  (Read 772 times)

Offline Baskakov_Dima

  • Fledgling
  • *
  • Posts: 6
  • Reputation: 0
Game refuses to use dedicated GPU
« on: January 07, 2017, 03:24:01 PM »
Windows 8.1 (64-bit), 8 GB RAM, Core i7 (4 cores), NVidia GeForce GTX 950M

The game doesn't see my laptop dedicated GPU as a graphics device and uses Intel HD Graphics instead. I can't run high resolutions due to that (1024x700 was the best thing I got) and can't use dinamic lighting since Intel HD Graphics doesn't seem to support it. I am in the beginning, in the mine, and I can't see anything even if I try to use a torch. I tried spawning a flashlight and a flare -- nothing changed. I tried switching the game manually to usage of GPU, using GPU is a general setting on my PC -- didn't work.

I also tried to turn HD graphics off -- it didn't help, game just refuses to start and crashes even before the video intro.

Other games seem to run on GPU.

Also two starting videos are very laggy.

All the problems are present in both unmodded version from and Age Of Redemption mod.

Thanks in advance.

Offline samspin

  • Administratrix
  • Neonate
  • *****
  • Posts: 72
  • Reputation: 5
Re: Game refuses to use dedicated GPU
« Reply #1 on: January 10, 2017, 11:53:59 PM »
It sounds like you have a newer laptop that has "switchable graphics".  What model is your laptop?
You mentioned your laptop has a discrete NVIDIA card, this support document might help (it is on Lenovo's help site, but it guides through NVIDIA's control panel).

As I know, the only other way to force legacy games to use the discrete graphics card is to disable integrated graphics completely. This could be either by going into Device Manager and right-click disabling the default Intel HD Graphics, or by restarting the laptop and entering the BIOS options to see if there is an option to manually select the NVIDIA card as default. I do happen to have a "switchable graphics" laptop in the form of a Macbook Pro, unfortunately in my case the default graphics is always set to NVIDIA anyway when booting Windows, as only macOS supports the switchable graphics (in my case Intel HD Graphics is always invisible to Windows, only visible to macOS). Therefore I can't investigate any further unless I know what specific model laptop you have. Please let me know if any of this info helps.
EDIT: This thread on AutoDesk's site talks through disabling Intel HD Graphics via the BIOS and mentions that the name of this "switchable graphics" is called NVIDIA Optimus.
« Last Edit: January 10, 2017, 11:57:44 PM by samspin »


* Game Files