collapse

Author Topic: Secure connection failed  (Read 2444 times)

Offline Acleacius

  • Antediluvian
  • *****
  • Posts: 922
Secure connection failed
« on: June 14, 2016, 05:51:15 PM »
Hi, thanks for all your work on this great site !   :rock:

I'm getting an issue where I can't connect with a secure connection, it tells me to try back later. I was connecting to the site fine, until about 11:30 am cst.


Fixed, by 12:00 pm noontime, cst.


« Last Edit: June 14, 2016, 06:09:45 PM by Acleacius »
Trust me, most of the names I have been called you can't translate in any language...they're not even real words as much as a succession of violent images.

Offline Acleacius

  • Antediluvian
  • *****
  • Posts: 922
Re: Secure connection failed
« Reply #1 on: August 22, 2016, 08:35:37 PM »
Getting this error again with my Firefox, anyone else experiencing it? I'm just not sure if it's me, since not happening on other sites. Don't think it's an addon, either.
Trust me, most of the names I have been called you can't translate in any language...they're not even real words as much as a succession of violent images.

Offline Acleacius

  • Antediluvian
  • *****
  • Posts: 922
Re: Secure connection failed
« Reply #2 on: August 22, 2016, 10:17:34 PM »
Working again, thanks!
Trust me, most of the names I have been called you can't translate in any language...they're not even real words as much as a succession of violent images.

Offline Wesp5

  • Administratrix
  • Antediluvian
  • *****
  • Posts: 6245
  • Unofficial Patcher
Re: Secure connection failed
« Reply #3 on: August 22, 2016, 10:20:07 PM »
Getting this error again with my Firefox, anyone else experiencing it?

I had the same issues the last days, but it's working again now...

Offline samspin

  • Administratrix
  • Ancillus
  • *****
  • Posts: 102
Re: Secure connection failed
« Reply #4 on: August 26, 2016, 02:30:40 AM »
To anyone having this error, are you running an Anti-virus software that does SSL scanning?
Apparently recent anti-virus programs do this to SSL sites by stripping the genuine certificate, scanning the connection, then adding their own self-generated certificate signed by a root installed by the anti-virus software itself. I've seen Avast! do this before and ended up having to turn off SSL scanning as it got in my way. The problem is, this kind of behaviour is *exactly* the kind that illicit people attempt to do, and I have Public Key Pinning (PKP) in place to prevent that kind of attack. PKP works by sending browsers a list of allowed keys in the server headers. This site's genuine certificate uses one of the allowed keys, a self-generated certificate made by an anti-virus program would not be on the list. This would explain browser errors saying the credentials are not correct. No matter how much I argue to the point I'm blue in the face, anti-virus companies insist on doing this kind of behaviour that is indistinguishable from actual attacks. I am going to remove PKP from the server to prevent from blocking legitimate users accidentally until anti-virus companies clean up their act.

Offline Grizzly_UK

  • Fledgling
  • *
  • Posts: 28
Re: Secure connection failed
« Reply #5 on: November 24, 2016, 11:00:55 PM »
Figured I should post about this, just started getting this "Secure Connection Failed" with Firefox today. Managed to use MS Edge to get to the site and found this thread. Noted samspin's reply above, especially the bit about Avast so tried adding the site's URL as an exclusion in my Avast and now the site loads just fine in Firefox!

Offline Grizzly_UK

  • Fledgling
  • *
  • Posts: 28
Re: Secure connection failed
« Reply #6 on: November 25, 2016, 05:06:40 PM »
Problem has returned in Firefox today! Just tried to visit the site and got the "Secure Connection Failed" message. If it helps, the message continues with this:

Quote
An error occurred during a connection to www.planetvampire.com. The OCSP server suggests trying again later. Error code: SEC_ERROR_OCSP_TRY_SERVER_LATER

Site loads fine in MS Edge, which is what I'm using now to post this message. The site's URL is still listed under the URL exclusion section in my Avast. Tried deleting and re-adding the site's URL as an exclusion, but it made no difference. I'm using Firefox v50.0 and Avast is up-to-date.

Any suggestions as to solving this problem please?

Offline Wesp5

  • Administratrix
  • Antediluvian
  • *****
  • Posts: 6245
  • Unofficial Patcher
Re: Secure connection failed
« Reply #7 on: November 25, 2016, 07:28:35 PM »
Any suggestions as to solving this problem please?

I have the same issue basically daily and I'm using Avira Antivir without browser protection so I don't think that Avast is the problem...

Offline Grizzly_UK

  • Fledgling
  • *
  • Posts: 28
Re: Secure connection failed
« Reply #8 on: November 26, 2016, 08:44:35 AM »
Any suggestions as to solving this problem please?

I have the same issue basically daily and I'm using Avira Antivir without browser protection so I don't think that Avast is the problem...
Yeah the problem seems to be intermittent as the site is now loading OK in Firefox once more. Wondering if this is only happening with Firefox as the site loads fine for me in MS Edge when it won't load in Firefox.

Offline samspin

  • Administratrix
  • Ancillus
  • *****
  • Posts: 102
Re: Secure connection failed
« Reply #9 on: November 28, 2016, 01:12:48 AM »
I've now turned off OCSP stapling after reading about this bug and there being no full solution two years after it's been brought up.
https://bz.apache.org/bugzilla/show_bug.cgi?id=57121
Hopefully now we shouldn't be getting this annoying error again...