collapse

* Notice

Important notice: Currently emails from this forum are being automatically blocked by many email providers, claiming Planetvampire.com has a "low reputation". As such you may struggle to register and/or submit password reset requests. If you require help, please email admin@planetvampire.com for assistance. In the meantime we are continuing to work on this issue.

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Protean 5 or Precache problem with model addon.  (Read 420 times)

Offline Numeneri

  • Fledgling
  • *
  • Posts: 4
  • Reputation: +0/-0
Protean 5 or Precache problem with model addon.
« on: October 07, 2022, 11:58:56 am »
I have a constant error with Protean 5 model swap on custom gangrel model made by Marius. Since author doesn't respond to it, I'm humbly asking for assitance of this good old forum. Problem occurs on Patch Plus and Clan Quest, didn't tested on Vanilla.
Just by the looks of it, it seems that the game wants to load Kerri's model. Is there a way to fix this mess?
Thanks in advance.
« Last Edit: October 07, 2022, 02:50:05 pm by Numeneri »

Offline Barabbah

  • Antediluvian
  • *****
  • Posts: 2440
  • Reputation: +49/-5
Re: Protean 5 or Precache problem with model addon.
« Reply #1 on: October 07, 2022, 07:43:40 pm »
I'm no model expert but maybe the game is searching for a model with that path/name and not finding it crashes itself.
Try to make a copy of the new gangrel .mdl file (or of Kerri's one), change its name to kerrixxxxxxxx.mdl and place it in that folder
"Some quotations," said Zellaby, "are greatly improved by lack of context."
― John Wyndham, The Midwich Cuckoos
"fuck the hole in the face"
― me

Offline Numeneri

  • Fledgling
  • *
  • Posts: 4
  • Reputation: +0/-0
Re: Protean 5 or Precache problem with model addon.
« Reply #2 on: October 08, 2022, 02:49:22 am »
I'm no model expert but maybe the game is searching for a model with that path/name and not finding it crashes itself.
Try to make a copy of the new gangrel .mdl file (or of Kerri's one), change its name to kerrixxxxxxxx.mdl and place it in that folder
Nah, it doesn't work like that, tried it first. A few search attempts and a diving session into the "bug history" of the VTMB modding left me with impression, that model swapping is some mirracle for the engine and it need to precache everything before loading the level. Perhaps, some script is missing.
I ain't stranger at fixing minor bugs myself, but I don't even know where even to start...
Hopefully, someone with experience would spot on my post.

Offline Malkav

  • Antediluvian
  • *****
  • Posts: 2079
  • Reputation: +400/-13
Re: Protean 5 or Precache problem with model addon.
« Reply #3 on: October 08, 2022, 07:55:47 am »
I have downloaded this skin yesterday. It includes an ancient version of engine.dll.  So if you installed the /bin directory from the mod, you have overwritten the more recent version of the dll provided by the patch.
Also the patch uses a new version of the female Gangrel model. So if you have installed the /materials and /models folders to /vampire as the mod does, there will be conflicts.
Maybe one of these issues is the reason for your problem.
To solve this you should reinstall the patch and then copy the /materials and /models folders from the mod to /unofficial_patch (and /cqm for use with that).
Co Author of Camarilla Edition Mod

Offline Numeneri

  • Fledgling
  • *
  • Posts: 4
  • Reputation: +0/-0
Re: Protean 5 or Precache problem with model addon.
« Reply #4 on: October 08, 2022, 03:38:07 pm »
I have downloaded this skin yesterday. It includes an ancient version of engine.dll.  So if you installed the /bin directory from the mod, you have overwritten the more recent version of the dll provided by the patch.
Also the patch uses a new version of the female Gangrel model. So if you have installed the /materials and /models folders to /vampire as the mod does, there will be conflicts.
Maybe one of these issues is the reason for your problem.
To solve this you should reinstall the patch and then copy the /materials and /models folders from the mod to /unofficial_patch (and /cqm for use with that).

So, in short:
Install new .dll (I've found a comment on moddb, which states that without it model looks like PS1 era one.), delete folders, replace with new one from Plus Patch and than install mod. Or what?

Offline Barabbah

  • Antediluvian
  • *****
  • Posts: 2440
  • Reputation: +49/-5
Re: Protean 5 or Precache problem with model addon.
« Reply #5 on: October 08, 2022, 06:41:40 pm »
Remove the .dll
Make a backup of the saves
Remove the UP folder
Reinstall the UP (make sure it's the same version you installed before or the saves will be uncompatible)
Put the saves back in their place
Reinstall the mod without that .dll


It should work although in the character sheet it will look bad (like a PS1 character)
« Last Edit: October 08, 2022, 06:58:30 pm by Barabbah »
"Some quotations," said Zellaby, "are greatly improved by lack of context."
― John Wyndham, The Midwich Cuckoos
"fuck the hole in the face"
― me

Offline Wesp5

  • Administratrix
  • Antediluvian
  • *****
  • Posts: 8368
  • Reputation: +926/-31
  • Unofficial Patcher
Re: Protean 5 or Precache problem with model addon.
« Reply #6 on: October 08, 2022, 08:42:27 pm »
It should work although in the character sheet it will look bad (like a PS1 character)
Shouldn't that be fixable with the SDK CharSheetInjector? I never heard of a dll that helped with this...

Offline Numeneri

  • Fledgling
  • *
  • Posts: 4
  • Reputation: +0/-0
Re: Protean 5 or Precache problem with model addon.
« Reply #7 on: October 08, 2022, 10:05:04 pm »
It should work although in the character sheet it will look bad (like a PS1 character)
Nah, nothing changes. Game still crashes on protean-to-normal model transformation.
Tested on fresh game, fresh installment.

BTW, my current playthrough is with CQM, if it would help somehow.

IDK why there is a python script in files and the whole vtmb modding confuses me... I don't even know where to look to learn anything about this problem. There was a mod that switches model midgame, it had some similar bugs too (before they've made a patchfix), perhaps, there is a way to force-load or pre-load necessary model.

And what bugs may occur with outdated .dll? Just in theory. I've alreary swapped it with new one, and yes, charsheet model is looking ugly (as any other custom model in preview)... Somehow, Marius's dll fixed it.
« Last Edit: October 08, 2022, 10:09:49 pm by Numeneri »

 

SimplePortal 2.3.7 © 2008-2023, SimplePortal