Vampire the Masquerade: Bloodlines > Bloodlines Tech Support

Bug reports, Issues and Solutions

(1/199) > >>

[archive] Wesp5:
                Post here any issues you have, and the solution you found for it.
 Compiled solutions post
 First posted by LeonX
 FAQ for common Vampire Bug Fixes:
 1. How can I enable the console?
 a. Right-click on the shortcut you use the launch the game
 b. Select properties
 c. Make sure you are on the shortcut tab
 d. At the end of the target line add -console, add this outside of the quotes
 e. The finished line should look like this if you have the game installed to the default directory:
 "C:\Program Files\Activision\Vampire - Bloodlines\vampire.exe" –console
 f. Hit ok, make sure you launch the game using this shortcut
 2. When leaving the Society of Leopold and jumping onto the boat to escape, the game crashes to desktop. What can I do?
 a. Make sure the console is enabled. (See Question #1 above)
 b. Get to the boat and approach it, do not get into the boat, but get as close as you can
 c. Open the console using the tilde "~" key
 d. Type the following commands in:
 If you saved Johansen:
 Then to level transition if you're anybody but a Nosferatu:
 changelevel2 la_hub_1 taxi_landmark
 And if you're a Nosferatu, instead use:
 changelevel2 la_hub_1 sewer_map_landmark
 e. If you get to the next level and you do not have any items in your inventory reload your previous save (make sure you have a discreet save and are not just using the autosave) and try it again, but stand closer to the boat."
 3. I am a Python user and I am having compatibility problems with my vampire_python211.dll.
 The workaround for the python problem is un-install your python2.1 interpreter and make sure the following registry key does not exist, manually deleting it if you must:
 If you need python interpreter installed, please install python2.3 or 2.4rc1 as they use a different registry variable.
 4. I get the following error message on launch: “The procedure entry point _AIL_set_redist_directory@4 could not be located in the dynamic link library mss32.dllâ€?
 An older version of mss32.dll resides in your windows\system or windows\system32 folder that is interfering with Vampire. If you delete this file from that folder, the game should work fine. However, whatever application was relying on older version to be there may no longer function.
 5. I am having performance problems on my system. Other than options already in the game, what are some things I can try to enhance performance?
 a. Before trying any of the below options, there are several audio and video enhancements options within Vampire. Note that some require you to restart your game after making the changes. If you are still unable to achieve acceptable performance after tweaking these options, then proceed to these additional possibilities.
 b. It is important to have a large enough swap file. To increase the size of your swap file, here is a link: <a class="BoardRowBLink" href=";en-us;314482#kb1">;en-us;314482#kb1</a>
 Note also that there is discussion about this topic at the Dilapidation forums:
 <a class="BoardRowBLink" href=""></a>
 c. It is possible that turning off your EAX (environmental audio effects) will help performance. There is a link here about this topic on the Dilapidation forums:
 <a class="BoardRowBLink" href=""></a>
 d. Some users have experienced increased performance by insuring that their AGB Aperture Size is no greater that 128MB. This is most likely configured via your motherboards BIOS setup screen. Please consult your motherboard manual for information on how to adjust your AGP Aperture size.
 d. Make sure to have the latest video drivers installed. For ATI cards, installing the 4.12b-Catalyst drivers has been known to help. For ATI cards, check:
 <a class="BoardRowBLink" href=""></a>
 ...and for Nvidia cards, check:
 <a class="BoardRowBLink" href=""></a>
 e. Some people have reported that turning off full screen anti-aliasing and anisotropic filtering from the video card settings has enhanced performance.
 f. Here are some other sites with discussions on enhancing performance:
 <a class="BoardRowBLink" href=""></a>
 <a class="BoardRowBLink" href=""></a>
 [added Dec  1 2004  8:31AM]
 Monitor frequency out of range
 vesselle wrote:
 ~ click on your start button &gt; run
 ~ enter: dxdiag
 ~ click OK
 ~ directx diagnostic tool opens
 ~ click on "more help" tab
 ~ click the "override" button
 ~ select "override value" and enter a value in the box that your monitor can support (60 usually), then click ok
 ~ exit the dxdiag via the exit button at the bottom or the "X" in the upper right
 Unable to move after exiting Console:
 Enter the game menu by pressing escape before opening the console.
 Then open the console, type in you command, exit the console, and cresume the game.                        <p> </p>-----signature-----<div id="ctl00_ctl00_cphMain_cphMain_ccSkin_ctl00_ucBoardTopicView_ccSkin_ctl00_rptMessages_ctl00_ucMessageView_ccSkin_ctl00_ucBoardSignature_lnlSignatureText" class="SignatureText">           Once you go Malk, you can't go back
 <link url="irc://">Bloodlines IRC</link>    </div>                                                    

[archive] Scorpion16146948:
                In Reply To #1
 Great job!  Very nicely written.  Kudos to you my man!

[archive] PaladinGunn:
                I deserve no credit for this, this is merely a repost from the original message by LeonX on the dilapidation forums, I just added a post by another user of the Dilapidation board.
 [added Dec  2 2004  2:20AM]
 Virtual Drives - CD/DVD emulation problems
 remove any CD/DVD emulation software you have installed
 and remember to CLEAN your Registry. Apparently, the copy protection check the registry for such softwares keys.
 [added Dec  2 2004  2:27AM]
 Exiting console freezes the game
 1. Enter the game menu by pressing escape
 2. open the console
 3. type in your command and exit the console
 4. resume game from the menu.
 [added Dec  2 2004  2:37AM]
 Original post by JAck Corbenon the Dilapidation forums
 This is with regards to the slow downs, stuttering. etc. I initally had when I first installed the game.
 These are the "main" things I did to significanlty improve performance.
 1) add "-heapsize 512000" to shortcut.
 2) Set pagefile size to 1.5 times my ram, in this case 1.5 GB, STATIC and CONTIGUOUS on a separate physical drive from windows and the game.
 These are the things I did which may or may not have contributed to any perfomance, but it seemed to smooth out graphics and sound stutter(I'm playing Malk now so it could all be in my head).
 1) 16XAF. I know it doesn't make sense as AF usually incurrs a performance penalty. I tried 4X, 8X and 16X and "seemed" smoother with as opposed to without. Try different settings as your mileage will undoubtedly vary. As an aside, Half Life 2 always ran with higher fps without AF.
 2) Froce DX9 with -dxlevel 90. Obviously you should force the right directx level appropriate for you hardware(substitute 70, 80 or 81 instead of 90). In Half Life 2 you know what dxlevel you're running in the advanced option screen. In VTM:B I wasn't sure so I just used the above switch in the shortcut.
 There are the things which had no apparent affect on performance on my rig. BUT JUST BECAUSE it didn't work for me doesn't mean it will not work for you. Again mileage will vary.
 1) With or without 4XAA. Again I can't explain this because in HL2 I always get higher fps with AA turned off.
 2) Setting the desktop resolution to 800X600. My only guess as to why this may work for some is that the lower res desktop uses less memory. So for memory starved systems this may have helped. It doesn't on mine.
 3) Turning EAX off. This had zero effect on the sound stuttering. In fact I did what gregmc3 suggested on page 2 of this thread to turn on surround sound (snd_surround "0" change 0 to 1) in the cfg file with no hit in performance. I played for about 4 hours with setting with no ctds. The occlussion and localization effects are much better now. although dialogue getting "drowned out" can be more apparent.
 Some stuttering is still present but minimized from before I made the first two fixes above. And my load times are down to about 20 secs for between hubs, and 10 secs within a hub.
 I now get get about 60 fps most places, 30-40 within the hubs, and about 20-30 in the hub while raining. It can still on occasion drop to about 15 when raining in the santa monica beach area near the water, but I'll take it.
 Specs are:
 P4 3.1
 1Gb DDR433
 2 35 Gb Raptor for windows, games and swap
 Gforce 6800Ultra OC
 SBAudigy 2
 1280X1024 4XAA 16XAF
 For some reason I never got degraded performance(memory leak?) like some even after 3-4 hours of play.
 [added Dec  2 2004  2:42AM]
 No clothes, and other various glitchs with the UK/European version
 Reinstall the game using the english language pack, since only people using the german or french installation have those bugs.
 [added Dec  2 2004  2:44AM]
 about drop in performances happening after a few consecutive hours of play
 open the console and type in "flush"
 this will help at least temporarily                         -----signature-----           Once you go Malk, you can't go back
 <link url="irc://">Bloodlines IRC</link>                                                       

[archive] fant0mas9:
                In Reply To #3
 you may wish to clarify
 " 1) add "-heapsize 512000" to shortcut."
 ie that it is dependent on the amount or ram you have. Also specify where/how to add it for those on the forums not so comp. literate
 Also with the size of the swap file, the box the game came in had a min requirement listed which people should refer to.
 And may wish to remove the links pointing back to dilapidation
 At work at moment so can't spend the time outlining it myself .                                                                            

[archive] enforcerbr:
                I've had the game for a few days now but I simply can't play it, it started alright at first when I played a Brujah, I went all the way to downtown but then the game started crashing to desktop every five minutes, i've tried most of the fixes but they don't seem to work.
  Now i've uninstalled the game, deleted the folder, reinstalled and the problem still persists, i'm playing it and suddenly it all locks up and i'm thrown back to the desktop, this sucks because i've experienced virtually 0% of the game.


[0] Message Index

[#] Next page

Go to full version